test:/weblogic/src#>cat env.sh
echo "export AIXTHREAD_SCOPE=S"          >> ~/.profile
echo "export AIXTHREAD_MNRATIO=1:1"      >> ~/.profile
echo "export MALLOCMULTIHEAP=1"          >> ~/.profile
echo "export SPINLOOPTIME=1000"          >> ~/.profile
echo "export YIELDLOOPTIME=10"           >> ~/.profile
echo "export AIXTHREAD_COND_DEBUG=OFF"   >> ~/.profile
echo "export AIXTHREAD_MUTEX_DEBUG=OFF"  >> ~/.profile
echo "export AIXTHREAD_RWLOCK_DEBUG=OFF" >> ~/.profile
echo "export MEMORY_AFFINITY=MCM"        >> ~/.profile
echo "export LDR_CNTRL=DATAPSIZE=64k@STACKPSIZE=64k@TEXTPSIZE=64k" >> ~/.profile
echo "dscrctl -n -s 1 "                  >> ~/.profile

chdev -l sys0 -a maxuproc='4096'
chdev -l sys0 -a iostat='true'

no -r -o tcp_sendspace=65536
no -r -o tcp_recvspace=65536
no -r -o udp_sendspace=65536
no -r -o tcp_recvspace=655360
no -r -o rfc1323=1              # Window scaling allows the TCP window sizes (tcp_recvspace and tcp_sendspace)
                                # to be larger than 64KB (65536) and is typically used for large MTU networks
no -r -o tcp_nodelayack=1       # TCP to send immediate Ack packets to the sender ( 0 -> 200ms)


no -r -o ipqmaxlen=512          # number of received packets that can be queued on the IP protocol input queue
no -r -o sb_max=1310720         # maximum buffer size allowed for a TCP and UDP socket
no -r -o somaxconn=4096         # maximum listen backlog
no -r -o tcp_finwait2=120       # FINWAIT2 check time - 120*(1/2) sec

no -r -o tcp_keepidle=14400
no -r -o tcp_keepinit=150
no -r -o tcp_keepcnt=8
no -r -o tcp_keepintvl=150
no -r -o rto_high=8 -o rto_limit=5 -o rto_length=5


vmo -r -o v_pinshm=1            # allow pinning of shared memory segments
# chuser capabilities=CAP_BYPASS_RAC_VMM,CAP_PROPAGATE $USER # change non-root user capability to access the large page
# vmo -o lgpg_regions=256 -o lgpg_size=16777216 # reseve the memory 16M(16777216) * 256


## /etc/security/limits
# fsize = -1
# core = -1
# cpu = -1
# data = -1
# rss = -1
# stack = -1
# stack_hard = -1
# nofiles = 10000
# nproc = 16384


## java execution command && option
# execrset -c ${start}-${end} -e java -Xlp -Xgcpolicy:gencon -Xaggressive
#       -XtlhPrefetch -XlockReservation -Xnoloa -Xcompressedrefs -cp aa.jar:bb.jar com.TESTMain &

'IBM Power' 카테고리의 다른 글

init.ora 기본 파라미터 변경 for 11gr2 on aix  (0) 2012.01.09
Oracle 10g control file 관리  (0) 2011.12.21
HMC CLI(Command Line Interface)  (0) 2011.11.28
CPU Folding 비활성화 (vpm_xvcpus)  (0) 2011.11.28
vios commands  (0) 2011.11.16
블로그 이미지

Melting

,